The Virtual Switching System (VSS) allows two Cisco Catalyst 6500 or 4500 chassis to bond together so that is seen as a single virtual switch to the rest of the network. Other devices will see the VSS configured 6500 as a single device which means it’s possible to use multi chassis ether channel and protocols like spanning-tree will only see a single switch. This article provides configuration that will allow you to easily enable VSS on these switches.
Here is a sample VSS configuration for 2x Cat6500 with Supervisor 720 provided by a Cisco champion.
VSS domain config:
switch virtual domain 10
switch 1
switch 1 priority 110
switch 2 priority 100
exit
Create a Port-Channel “mode on” type between two Supervsor:
interface port-channel 1
description VSL Link
switch virtual link 1
no sh
interface range T5/4 -5
channel-group 1 mode on
no shutdown
Commiting following command will save the configuration on both switches and reboot them.
switch convert mode virtual
After the reboot, we need additionally apply this command:
switch accept mode virtual
Now, lets verify the VSS status:
show switch virtual
show switch virtual link
show switch virtual role
Remember to apply this also:
mac-address-table synchronize
redundancy
mode sso
exit
Sample from Cisco’s support forums https://supportforums.cisco.com/document/134471/konfiguracja-vss-na-6500
So in the following part we will share a general example of Cisco Cat6500 VSS Configuration
Firstly, let’s check the main requirements for this Configuration on the Catalyst 6500 series.
Requirements
- Virtual Switching Supervisor 720-10GE (VS-S720-10GE-3C and VS-S720-10GE-3CXL) with IOS 12.2(33)SXH1 and IP Base
- or Supervisor 2T (VS-S2T-10G and VS-S2T-10G-XL) with IOS 12.2(50) SY and IP Base
Cabling Between Chassis
- Minimum of two 10Gbps links with at least one on the Supervisor
- Minimum of one (more is recommended) 1Gbps or 10Gbps links for dual-active detection
Dual Active Detection Method
There are three available options; BFD, Fast Hello, Enhanced PAgP. EPAgP requires a downstream switch that is EPAgP-capable, which is sometime hard to find. BFD requires an IP address to be configured on the interface. Here we choose to use Fast Hello, although more than one method can be configured.
Configuration Steps:
Make sure all cabling between two switches are completed before proceeding
On Switch 1
1. Set switch number to 1
!
switch set switch_num 1 local
switch read switch_num local ! confirm 1 is returned
!
2. Configure virtual domain then save config
!
configure terminal
switch virtual domain 1
switch 1
mac-address use-virtual ! optional but recommended
!
do wr mem
!
3. Configure VSL links.
!
interface Port-channel 1
desc — To Switch 2 VSL —
switchport
switch virtual link 1
no shut
!
interface range TenGigabitEthernetx/x-y ! modify as necessary
channel-group 1 mode on
no shutdown
!
do wr mem
exit
!
4. Convert switch to VSS mode. Confirm and switch will reload
!
switch convert mode virtual
!
On Switch 2
1. Set switch number to 2
!
switch set switch_num 2 local
switch read switch_num local ! confirm 2 is returned
!
2. Configure virtual domain then save config
!
configure terminal switch virtual domain 1 switch 2 mac-address use-virtual ! optional but recommended ! do wr mem ! |
3. Configure VSL links.
!
interface Port-channel 2 ! must be different number from switch 1 desc — To Switch 1 VSL — switchport switch virtual link 2 no shut ! interface range TenGigabitEthernetx/x-y ! modify as necessary channel-group 2 mode on no shutdown ! do wr mem exit ! |
4. Convert switch to VSS mode. Confirm and switch will reload
!
switch convert mode virtual ! |
- Wait until switch 2 comes back and join VSS
- You can only make config changes on the active supervisor now
On the active switch
1. Adjust switch priority
!
configure terminal switch virtual domain 1 switch 1 priority 110 switch 2 priority 100 ! |
2. Configure dual-active detection
!
switch virtual domain 1 dual-active detection fast-hello ! interface ra GigabitEthernet1/x/x ! modify as necessary desc — VSL Fast Hello — dual-active fast-hello no shutdown ! interface ra GigabitEthernet2/x/x ! modify as necessary desc — VSL Fast Hello — dual-active fast-hello no shutdown exit ! show switch virtual dual-active fast-hello ! verify ! |
Reference from https://www.labminutes.com/blog/2013/09/cisco-4500-4500x-6500-vss-configuration
More Related VSS Configuration on Cisco Switches